Handmade quality · Free shipping over $75 · Explore the atelier

192GB (2x96GB) DDR5 PC5-4800B-R PC5-38400R ECC Registered Server Memory Upgrade Kit Western Digital it is ideal for integration

SKU: 20178953857

4.3
USD5400.00 USD5448.00

Pay in 4 interest-free payments of $1350.00 Learn more

Shipping Estimate
USA
  • USA
  • CAN

Ships within 48 hours · Estimated delivery Oct 4 - Oct 9

Description

it is ideal for integration into modular FRL assemblies

Remote and edge IT installations needing remote control

Capacity: 2TB SED

1AB Link Layer Discovery Protocol (LLDP) RFC 1215 Convention for Defining Traps for use with the SNMP RFC 2579 Textual Conventions for SMIv2 RFC 2580 Conformance Statements for SMIv2 RFC 2818 HTTP over TLS RFC 2819 Four groups of RMON: 1 (statistics)

and 60 and capable of managing up to 240 drives via SAS expander for Supermicro server platforms

192GB (2x96GB) DDR5 PC5-4800B-R PC5-38400R ECC Registered Server Memory Upgrade Kit Western Digital it is ideal for integrationProduct Details Module Name: PC5 4800B R PC5 38400 Speed: 4800MT s Data Integrity Check: ECC Kit Storage Capacity: 192GB (2x96GB) Condition: Fully Tested, Refurbished, New Warranty: 1 Year Warranty Compatible with: Dell Rackmounts: N A

Exchange/Return Notes
  • We offer a 30-day return/exchange service after receiving.
  • Final sale items are not eligible for returns or exchanges.
  • To process your return/exchange, please contact us at [email protected]
  • Please click here for more details>>> Return & Exchange Policy

You may also like

recommand products